Crediting delays on Spanish bank accounts
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 14:30 CEST
Identified
We are currently facing a technical issue impacting our crediting processes on some of our Spanish bank accounts. The issue has been identified and is currently in process of resolution.

As a result, you will experience a delay regarding incoming bank transfers.

We are sorry for the inconvenience.
Posted Aug 12, 2022 - 10:29 CEST
This incident affected: BackOffices.