Crediting Delay Identified
Incident Report for Lemonway
Resolved
Automatic processing has been completed.
Posted Jun 18, 2024 - 09:34 CEST
Identified
We are currently facing an issue impacting our crediting processes.

As a result, you might experience a delay regarding :

- Incoming transfers
- SDD
- Checks
- Chargebacks

We are really sorry for the inconvenience it might cause.
Posted Jun 18, 2024 - 08:54 CEST
This incident affected: BackOffices.