External Disruptions - 3D Secure Authentication

Incident Report for Lemonway

Resolved

Dear Partners,

Our PSP has confirmed that the incident was resolved as of 11:04 AM today.

Best regards,
The Lemonway Team
Posted Jun 25, 2025 - 12:30 CEST

Update

We are continuing to investigate this issue.
Posted Jun 25, 2025 - 12:29 CEST

Investigating

Dear Partners,

One of our PSPs informs us that major perturbations have been noticed on 3DSecure service since 09:50 on 25/06/2025.

The point is under investigation.

We apologize for the inconvenience and will keep you informed.

The Lemonway Team
Posted Jun 25, 2025 - 11:51 CEST
This incident affected: Production (Production Webkit).