Crediting Delay Identified (to be changed accordingly)
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 14:46 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2021 - 14:20 CEST
Identified
We are currently facing an issue impacting our crediting processes.

As a result, you might experience a delay regarding :

- Incoming transfers
- SDD
- Chargebacks


We are really sorry for the inconvenience it might cause.
Posted Jul 22, 2021 - 10:15 CEST
This incident affected: BackOffices.