Crediting Delay Monitoring
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Nov 24, 2022 - 16:32 CET
Monitoring
A fix has been implemented and our Team is closely monitoring the issue, everything should back to normal. We will inform you once it is resolved.
Posted Nov 23, 2022 - 14:43 CET
This incident affected: BackOffices.