Crediting Delay Identified
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 14:58 CEST
Identified
We are currently facing a bank statement issue impacting our crediting processes.

As a result, you might experience a delay regarding incoming transfers to Barclays Italians and Germans accounts.

We are really sorry for the inconvenience it might cause.
Posted Oct 10, 2024 - 09:37 CEST
This incident affected: BackOffices.