External Disruptions - 3D Secure Authentication and Enrollment

Incident Report for Lemonway

Resolved

Dears customers,

Our partner informs us that the incident has been resolved since 17:11.
Posted Apr 14, 2025 - 17:48 CEST

Investigating

Dear clients,

One of our PSPs informs us that major perturbations have been noticed on 3DSecure service since 15h17.

The point is under investigation.
Posted Apr 14, 2025 - 16:19 CEST