Crediting Delay Identified
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Dec 30, 2022 - 11:12 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 30, 2022 - 10:09 CET
Identified
We are currently facing a technical issue impacting our crediting processes.

As a result, you might experience a delay regarding :

- Incoming transfers
- Chargebacks
- SDD
- Checks

We are really sorry for the inconvenience it might cause.
Posted Dec 30, 2022 - 10:03 CET
This incident affected: BackOffices.