Crediting Delay Identified on Italian Bank Accounts
Incident Report for Lemonway
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 12:39 CET
Identified
We are currently facing an issue impacting our crediting processes regarding transfers received on Italian bank accounts.

We are in contact with our Banking Partner to solve the problem.

As a result, you might experience a delay regarding :

- Incoming transfers

We are really sorry for the inconvenience it might cause.
Posted Dec 02, 2021 - 12:15 CET
This incident affected: BackOffices.