Delays on Spanish Accounts Due to Bank Statement Issue

Incident Report for Lemonway

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 08:20 CEST

Identified

We are currently experiencing delays in receiving bank statements for our Spanish accounts from our banking partner.

As a result, you may experience delays with:

• Incoming transfers

We are really sorry for the inconvenience it might cause.
Posted Jun 16, 2026 - 09:12 CEST
This incident affected: Production (Production Dashboard).