Crediting Delay Identified for Barclays DE and IT Accounts

Incident Report for Lemonway

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 19:38 CEST

Identified

We are currently facing a bank statement issue with Barclays (DE and IT accounts), impacting our crediting processes.

As a result, you might experience a delay regarding:
- Incoming transfers

We are really sorry for the inconvenience it might cause.
Posted Jul 07, 2026 - 09:43 CEST
This incident affected: Production (Production Dashboard).